Ultimate space simulation software

 
User avatar
Himself
Space Tourist
Space Tourist
Topic Author
Posts: 29
Joined: 25 Jan 2017

Image editing software and custom ring textures

06 Feb 2018 21:51

I found an odd bug a while ago when I created ring textures for some of the planets I made: the gaps in the rings were not displaying properly when lit from behind. Even when tried to make doubly sure that that part of the texture was transparent, it would not appear properly. I had originally made all the textures using an older version of Adobe Photoshop Elements.
I recently found that if I opened the texture file and saved a copy in Paint 3D, even without making any edits, that gaps would render properly. Why would that make a difference?

Vilsandi-rings.png
Original Rings
Vilsandi-rings.png (3.08 KiB) Viewed 480 times
Vilsandi-rings2.png
Paint 3D copy
Vilsandi-rings2.png (535 Bytes) Viewed 480 times
Attachments
scr00116.jpg
Original Rings
scr00115.jpg
Paint 3D copy
 
Mr. Abner
Explorer
Explorer
Posts: 215
Joined: 08 Jun 2017
Location: Mississauga

Image editing software and custom ring textures

07 Feb 2018 18:16

I don't think this is an SE bug, but rather the image format. Technically, png file format does not support transparencies. It would appear that Adobe sticks to the letter of the law with the format, while Paint 3D works around it. (Big file size difference between the two also!)
 
User avatar
Himself
Space Tourist
Space Tourist
Topic Author
Posts: 29
Joined: 25 Jan 2017

Image editing software and custom ring textures

08 Feb 2018 20:44

I figured it might not have to do with SE specifically. It's interesting since the catalog rings are in png format. IIRC the ring texture files I made are edited copies of Chariklo's ring file.

Who is online

Users browsing this forum: No registered users and 1 guest