Ultimate space simulation software

  • 1
  • 2
  • 3
  • 4
  • 5
  • 7
 
User avatar
SpaceEngineer
Author of SpaceEngine
Author of SpaceEngine
Topic Author
Posts: 1049
Joined: 17 May 2016
Location: Saint-Petersburg
Contact:

Localizations

12 Jul 2019 11:35

In what language?
 
User avatar
SCP-10492
Astronaut
Astronaut
Posts: 40
Joined: 18 May 2019
Location: Earth

Localizations

12 Jul 2019 22:27

SpaceEngineer wrote:
In what language?

Simplified Chinese and Traditional Chinese. They seem to be machine translated. There are many mistakes. I'm trying to fix them.
Does anybody really look at this?
 
User avatar
SCP-10492
Astronaut
Astronaut
Posts: 40
Joined: 18 May 2019
Location: Earth

Localizations

13 Jul 2019 00:39

These are the language files that I have modified.
Attachments
chs-gui.cfg
(146.59 KiB) Downloaded 26 times
cht-gui.cfg
(149.04 KiB) Downloaded 22 times
Does anybody really look at this?
 
User avatar
Mosfet
Star Engineer
Star Engineer
Posts: 1391
Joined: 24 Oct 2016
Location: Italy
Contact:

Localizations

16 Jul 2019 13:14

Test-unicode version for Italian GUI 0.990.37.1670 corrected and updated, tutorials included. Wiki database doesn't seem converted yet, do you need that converted too?
Despite some missing glyphs, using unicode fonts is a pleasure, all those accents finally available! :D
Attachments
ita-gui.cfg
(166.86 KiB) Downloaded 16 times
"Time is illusion. Lunchtime doubly so". Douglas N. Adams
My mods | My specs: Asus x555ub - cpu i5-6200u, ram 4gb, gpu nvidia geforce 940m 2gb vram | IRC freenode.net canale ##SpaceEngineITA
 
User avatar
JackDole
Star Engineer
Star Engineer
Posts: 1587
Joined: 02 Nov 2016
Location: Terra

Localizations

16 Jul 2019 22:29

German translation file for version 0.990.37.1670 beta.
ger-gui.cfg
(182.95 KiB) Downloaded 17 times

I have added the few new lines.
JackDole's Universe 0.990: http://forum.spaceengine.org/viewtopic.php?f=3&t=546
JackDole's Archive: http://forum.spaceengine.org/viewtopic.php?f=3&t=419
JackDole: Mega structures ... http://old.spaceengine.org/forum/17-3252-1 (Old forum)
 
User avatar
SpaceEngineer
Author of SpaceEngine
Author of SpaceEngine
Topic Author
Posts: 1049
Joined: 17 May 2016
Location: Saint-Petersburg
Contact:

Localizations

17 Jul 2019 10:28

Don't adjust width of strings, fonts in the build 1670 are not final.

Mosfet, is this translation correct? Is the ' key on Italian keyboard replaced with à key?

Now press the ['] key         Ora premi il tasto [à]
press the ['] key twice        premi due volte il tasto [à]

Mosfet wrote:
Source of the post Wiki database doesn't seem converted yet, do you need that converted too?

Oh, I missed it.

Mosfet wrote:
Source of the post Despite some missing glyphs, using unicode fonts is a pleasure, all those accents finally available!

Which glyphs are missed? What is their unicode codes?
 
User avatar
SpaceEngineer
Author of SpaceEngine
Author of SpaceEngine
Topic Author
Posts: 1049
Joined: 17 May 2016
Location: Saint-Petersburg
Contact:

Localizations

17 Jul 2019 13:16

To everyone: please add "Chinese" and "Japanese" to the TranslationsScript {}, below // Languages. This will be used in the credits file.
 
User avatar
Atlantean
Observer
Observer
Posts: 5
Joined: 26 Jun 2017
Location: Celestis → Atlantis
Contact:

Localizations

17 Jul 2019 14:04

SpaceEngineer wrote:
Which glyphs are missed? What is their unicode codes?

se.log
(8.39 KiB) Downloaded 12 times
█▒█ ███ ▒█▒ ███ █▒█ ███ █▒█ █▒█ ███ ███
███ ▒▒█ ▒██ █▒█ ▒▒▒ █▒▒ ███ ██▒ ▒▒▒ ▒▒▒
█▒█ ███ ███ █▒█ ███ █▒▒ █▒█ ▒██ █▒█ ▒█▒
█▒▒ ▒▒█ █▒█ █▒█ █▒█ █▒▒ █▒▒ █▒█ ███ ███
 
User avatar
JackDole
Star Engineer
Star Engineer
Posts: 1587
Joined: 02 Nov 2016
Location: Terra

Localizations

17 Jul 2019 22:28

I presume that all scripts will have to be in Unicode format in the future, not in Ansi anymore?
JackDole's Universe 0.990: http://forum.spaceengine.org/viewtopic.php?f=3&t=546
JackDole's Archive: http://forum.spaceengine.org/viewtopic.php?f=3&t=419
JackDole: Mega structures ... http://old.spaceengine.org/forum/17-3252-1 (Old forum)
 
User avatar
SCP-10492
Astronaut
Astronaut
Posts: 40
Joined: 18 May 2019
Location: Earth

Localizations

18 Jul 2019 00:17

I think that the new version in the public branch and beta branch still uses ANSI encoding, while the new version in the test-unicode branch uses Unicode encoding may be better, but it may cause version confusion. If they update the same functionality, maybe some identifiers should be added to the version number? (e.g. 0.990.37.1675a, 0.990.37.1675u, etc.)
Does anybody really look at this?
 
User avatar
Mosfet
Star Engineer
Star Engineer
Posts: 1391
Joined: 24 Oct 2016
Location: Italy
Contact:

Localizations

18 Jul 2019 03:33

SpaceEngineer wrote:
Source of the post Mosfet, is this translation correct? Is the ' key on Italian keyboard replaced with à key?

Now press the ['] key         Ora premi il tasto [à]
press the ['] key twice        premi due volte il tasto [à]

Yes, exactly. I didn't noticed before because of my familiarity with program commands, but in a standard italian keyboard that's the key. http://kbd-intl.narod.ru/english/layouts
Same thing with [ and ] keys for magnitude limit (in italian keyboards they are available only as combinations with an "Alt Gr" key), wich in ita keyboard became ' and ì    . I changed that accordingly in tutorials.

As for missing glyphs, I see several warnings in se.log:
Line 1417: [MT] ERROR: seFont::AddGlyph(): Glyph 65523 (0xfff3) is not present in fonts
    Line 1418: [MT] ERROR: seFont::AddGlyph(): Glyph 65526 (0xfff6) is not present in fonts
    Line 1421: [MT] ERROR: seFont::AddGlyph(): Glyph 149 (0x95) is not present in fonts
    Line 1422: [MT] ERROR: seFont::AddGlyph(): Glyph 135 (0x87) is not present in fonts
    Line 1423: [MT] ERROR: seFont::AddGlyph(): Glyph 135 (0x87) is not present in fonts
    Line 1425: [MT] ERROR: seFont::AddGlyph(): Glyph 145 (0x91) is not present in fonts
    Line 1426: [MT] ERROR: seFont::AddGlyph(): Glyph 130 (0x82) is not present in fonts
    Line 1427: [MT] ERROR: seFont::AddGlyph(): Glyph 149 (0x95) is not present in fonts
    Line 1565: [MT] ERROR: seFont::AddGlyph(): Glyph 134 (0x86) is not present in fonts
    Line 1571: [MT] ERROR: seFont::AddGlyph(): Glyph 134 (0x86) is not present in fonts
    Line 1594: [MT] ERROR: seFont::AddGlyph(): Glyph 153 (0x99) is not present in fonts
    Line 1628: [MT] ERROR: seFont::AddGlyph(): Glyph 155 (0x9b) is not present in fonts
    Line 1641: [MT] ERROR: seFont::AddGlyph(): Glyph 2087 (0x827) is not present in fonts
    Line 1642: [MT] ERROR: seFont::AddGlyph(): Glyph 2084 (0x824) is not present in fonts
    Line 1643: [MT] ERROR: seFont::AddGlyph(): Glyph 128 (0x80) is not present in fonts
    Line 1644: [MT] ERROR: seFont::AddGlyph(): Glyph 158 (0x9e) is not present in fonts
    Line 1660: [MT] ERROR: seFont::AddGlyph(): Glyph 149 (0x95) is not present in fonts
    Line 1661: [MT] ERROR: seFont::AddGlyph(): Glyph 135 (0x87) is not present in fonts
    Line 1662: [MT] ERROR: seFont::AddGlyph(): Glyph 145 (0x91) is not present in fonts
    Line 1663: [MT] ERROR: seFont::AddGlyph(): Glyph 130 (0x82) is not present in fonts
    Line 1664: [MT] ERROR: seFont::AddGlyph(): Glyph 134 (0x86) is not present in fonts
    Line 1665: [MT] ERROR: seFont::AddGlyph(): Glyph 2087 (0x827) is not present in fonts
    Line 1666: [MT] ERROR: seFont::AddGlyph(): Glyph 2084 (0x824) is not present in fonts
    Line 1667: [MT] ERROR: seFont::AddGlyph(): Glyph 134 (0x86) is not present in fonts


and sun, moon, jupiter etc symbols that I believe are linked to BBCodes, like greek letters in stars. So you see something like
" Orionis / Betelgeuse" in GUI.

Edit:
I forgot to say that I'm playing with Waypoints with unicode fonts with this surface labels addon I'm preparing, it's using proper utf-8 characters in labels. It adds surface labels to known objects of solar system, like moon craters and such. Probably this is related.
Attachments
SurfaceLabelsV05.pak
(91.98 KiB) Downloaded 16 times
"Time is illusion. Lunchtime doubly so". Douglas N. Adams
My mods | My specs: Asus x555ub - cpu i5-6200u, ram 4gb, gpu nvidia geforce 940m 2gb vram | IRC freenode.net canale ##SpaceEngineITA
 
User avatar
Mosfet
Star Engineer
Star Engineer
Posts: 1391
Joined: 24 Oct 2016
Location: Italy
Contact:

Localizations

18 Jul 2019 05:32

SpaceEngineer wrote:
Source of the post please add "Chinese" and "Japanese"

Done.
Attachments
ita-gui.cfg
(166.91 KiB) Downloaded 13 times
"Time is illusion. Lunchtime doubly so". Douglas N. Adams
My mods | My specs: Asus x555ub - cpu i5-6200u, ram 4gb, gpu nvidia geforce 940m 2gb vram | IRC freenode.net canale ##SpaceEngineITA
 
User avatar
JackDole
Star Engineer
Star Engineer
Posts: 1587
Joined: 02 Nov 2016
Location: Terra

Localizations

18 Jul 2019 09:19

ger-gui.cfg
(183.05 KiB) Downloaded 18 times
JackDole's Universe 0.990: http://forum.spaceengine.org/viewtopic.php?f=3&t=546
JackDole's Archive: http://forum.spaceengine.org/viewtopic.php?f=3&t=419
JackDole: Mega structures ... http://old.spaceengine.org/forum/17-3252-1 (Old forum)
 
User avatar
JackDole
Star Engineer
Star Engineer
Posts: 1587
Joined: 02 Nov 2016
Location: Terra

Localizations

18 Jul 2019 20:55

ger-db.cfg
(922.64 KiB) Downloaded 46 times
JackDole's Universe 0.990: http://forum.spaceengine.org/viewtopic.php?f=3&t=546
JackDole's Archive: http://forum.spaceengine.org/viewtopic.php?f=3&t=419
JackDole: Mega structures ... http://old.spaceengine.org/forum/17-3252-1 (Old forum)
 
User avatar
SpaceEngineer
Author of SpaceEngine
Author of SpaceEngine
Topic Author
Posts: 1049
Joined: 17 May 2016
Location: Saint-Petersburg
Contact:

Localizations

19 Jul 2019 02:45

JackDole wrote:
Source of the post I presume that all scripts will have to be in Unicode format in the future, not in Ansi anymore?

Scripts must use only English letters and digits, so this doesn't matter (UTF8 with English coincides with UTF-8). Comments can be in other language, but SE ignores them anyway. Any text used in scripts (object names, tutorials) must be in English, and translated only by loc-gui.cfg TranslatiosScript { } (I will implement ability to mod this, i.e. add a custom -gui.cfg file to the addons folder).
  • 1
  • 2
  • 3
  • 4
  • 5
  • 7

Who is online

Users browsing this forum: No registered users and 1 guest