Free planetarium

 
nialv7
Observer
Observer
Topic Author
Posts: 1
Joined: 18 Jan 2017

Running SE under Linux (Wine, Mesa, etc)

18 Jan 2017 13:43

I figured out why SpaceEngine won't run under wine. SpaceEngine creates a non-core OpenGL profile using wglCreateContext, but then try to compile GLSL shaders with "#version 330 core", which fails under Mesa GL.

I did some hacking to redirect the call and now it works fine on my machine. In theory, forcing a GL version using MESA_GL_VERSION_OVERRIDE should work, except there's a bug in Wine which causes it to crash.

BTW, if you are having crashes in openal32, just delete the openal32.dll file.
 
lucas
Observer
Observer
Posts: 5
Joined: 03 May 2017

Publications about SE

30 Aug 2017 15:31

Hello,

I just published an article about space engine on my personal blog,
about running space engine on linux.

Can someone with enough posts creates a thread in the Troubleshooting & Solutions section (or whatever section it best belongs to) ?

I think many peoples could use these information.


PS: there is another article, about an implementation of the ultimate engineered solar system.
 
User avatar
RockoRocks
Observer
Observer
Posts: 12
Joined: 10 Sep 2017
Location: Torhout, Belgium

Wine, Mesa and SpaceEngine 0.9.8

11 Sep 2017 09:51

How exactly did you manage to do this? Does anybody know more about how to make this happen?
 
User avatar
FastFourierTransform
Space Pilot
Space Pilot
Posts: 94
Joined: 17 Nov 2016

Wine, Mesa and SpaceEngine 0.9.8

11 Sep 2017 13:18

How exactly did you managed to open a new thread without posting even once before? Also hacking the forum?  :D
 
User avatar
SpaceEngineer
Author of SpaceEngine
Author of SpaceEngine
Posts: 433
Joined: 17 May 2016
Location: Saint-Petersburg
Contact:

Wine, Mesa and SpaceEngine 0.9.8

11 Sep 2017 13:40

0.9.8.1 will have an option to switch to GL core profile. More specifically, GL desired version could be selected through the config.
 
User avatar
Mosfet
World Builder
World Builder
Posts: 659
Joined: 24 Oct 2016
Location: Italy

Wine, Mesa and SpaceEngine 0.9.8

11 Sep 2017 14:12

FastFourierTransform wrote:
Source of the post How exactly did you managed to open a new thread without posting even once before? Also hacking the forum?

Most likely an admin/mod did the job :)
But that's excellent news, nialv7, now I only need to tame dual graphics in xubuntu.
"Time is illusion. Lunchtime doubly so". Douglas N. Adams
My mods | My specs: Asus x555ub - cpu i5-6200u, ram 4gb, gpu nvidia geforce 940m 2gb vram | IRC freenode.net canale ##SpaceEngineITA
 
User avatar
RockoRocks
Observer
Observer
Posts: 12
Joined: 10 Sep 2017
Location: Torhout, Belgium

Wine, Mesa and SpaceEngine 0.9.8

11 Sep 2017 15:00

This is absolutely fantastic news indeed! Thank you very much, SpaceEngineer, I will use SpaceEngine on Windows 7 for now until 0.9.8.1 comes out.
 
lucas
Observer
Observer
Posts: 5
Joined: 03 May 2017

Wine, Mesa and SpaceEngine 0.9.8

12 Sep 2017 01:57

Space Engine runs fine under wine ; it just depends of which version is used (to my experience, 2.14 is fine, 2.15 is not).

Source: i'm playing Space Engine under linux using wine.

Thanks for the openal trick, though.
 
User avatar
RockoRocks
Observer
Observer
Posts: 12
Joined: 10 Sep 2017
Location: Torhout, Belgium

Wine, Mesa and SpaceEngine 0.9.8

12 Sep 2017 10:37

It sadly doesn't appear to work for me, not even using Wine 2.14
 
lucas
Observer
Observer
Posts: 5
Joined: 03 May 2017

Wine, Mesa and SpaceEngine 0.9.8

12 Sep 2017 13:27

Ow, i'm sorry about that.

As your trick did the job,
can i link to this post in my tutorial ?
 
Huene
Observer
Observer
Posts: 2
Joined: 13 Sep 2017

Wine, Mesa and SpaceEngine 0.9.8

13 Sep 2017 13:04

MESA_GL_VERSION_OVERRIDE=3.3COMPAT wine ./SpaceEngine.exe


This seems to get you into the game, but there seems to be an issue with planet textures, I'm trying to find out now if it's the same issue reported elsewhere regarding atioglxx.dll

I have placed the suggested one in the system folder and did not get textures back just yet, still working on it
 
Huene
Observer
Observer
Posts: 2
Joined: 13 Sep 2017

Wine, Mesa and SpaceEngine 0.9.8

13 Sep 2017 13:25

I don't seem to have a way to edit my last post so here's what got it working for me, I launch the game with this 
MESA_GL_VERSION_OVERRIDE=4.5COMPAT wine ./SpaceEngine.exe

After applying the DLL fix from here: https://www.reddit.com/r/spaceengine/comments/2qwut0/so_a_lot_of_planets_are_seethrough_mostlikely_a/
And did so on the following hardware:
System:    Host: home Kernel: 4.12.12-19.current x86_64 bits: 64 Desktop: Budgie 10.4  Distro: Solus 3
Machine:   Device: desktop System: Dell product: XPS 8500 serial: N/A
           Mobo: Dell model: 0YJPT1 v: A00 serial: N/A BIOS: Dell v: A12 date: 08/28/2013
CPU:       Quad core Intel Core i7-3770 (-HT-MCP-) speed/max: 1681/3900 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X]
           Display Server: x11 (X.Org 1.18.4 ) drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: [email protected]
           OpenGL: renderer: Gallium 0.4 on AMD CAPE VERDE (DRM 2.50.0 / 4.12.12-19.current, LLVM 4.0.1)
           version: 4.5 Mesa 17.1.8
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           Card-3: Atheros
Drives:    HDD Total Size: 2032.4GB (14.6% used)
Info:      Processes: 324 Uptime: 1 day Memory: 2588.3/12043.0MB Client: Shell (sysinfo) inxi: 2.3.38 

 
User avatar
Mosfet
World Builder
World Builder
Posts: 659
Joined: 24 Oct 2016
Location: Italy

Wine, Mesa and SpaceEngine 0.9.8

13 Sep 2017 14:12

Thanks Huene, you'll be able to edit your posts and create threads after 10 posts.
"Time is illusion. Lunchtime doubly so". Douglas N. Adams
My mods | My specs: Asus x555ub - cpu i5-6200u, ram 4gb, gpu nvidia geforce 940m 2gb vram | IRC freenode.net canale ##SpaceEngineITA
 
User avatar
RockoRocks
Observer
Observer
Posts: 12
Joined: 10 Sep 2017
Location: Torhout, Belgium

Running SE under Linux (Wine, Mesa, etc)

15 Sep 2017 09:51

Thank you for sharing a possible solution Huene, butit sadly does not seem to work either for me, as I just get a popup saying "Cannot create the log file check access to SpaceEngine Folder".

Who is online

Users browsing this forum: No registered users and 3 guests