Ultimate space simulation software

 
User avatar
Jokel317
Observer
Observer
Posts: 4
Joined: 06 Apr 2017

Retro-Visor's Planetary Systems

30 Jan 2018 01:21

Was looking forward to this! Nice addition to the excellent mods! I do not see a user-eng-db.cfg file inside my main Spaceengine/config directory. Do you have to make this file then copy from the user-eng-db - Sikian.cfg? Or is the SE program suppose to make it originally? I am using 0.980e version thank`s.
 
 
User avatar
SpaceEngineer
Author of SpaceEngine
Author of SpaceEngine
Posts: 724
Joined: 17 May 2016
Location: Saint-Petersburg
Contact:

Retro-Visor's Planetary Systems

30 Jan 2018 01:24

Good work, interesting reading! One day SE will need a custom systems for a storyline, and I know who can create those! :)
A minor note: description file is in Unicode. Some of the quotation marks « » are displayed as two symbols in SE. Check out description of Lambert.
 
User avatar
JackDole
World Builder
World Builder
Posts: 1044
Joined: 02 Nov 2016
Location: Terra

Retro-Visor's Planetary Systems

30 Jan 2018 03:49

Jokel317 wrote:
Source of the post I do not see a user-eng-db.cfg file inside my main Spaceengine/config directory.

You can create this file by hand.
But this file is created when you give an object its own name. You can do that in the info window. (Wiki) (Key i)
Respectively for the language set in SpaceEngine. (For russian it would be 'user-rus-db.cfg'.)
 
User avatar
Jokel317
Observer
Observer
Posts: 4
Joined: 06 Apr 2017

Retro-Visor's Planetary Systems

30 Jan 2018 21:10

Thank you!
 
User avatar
tRetro-Visor
Explorer
Explorer
Topic Author
Posts: 177
Joined: 03 Nov 2016
Location: Chile
Contact:

Retro-Visor's Planetary Systems

02 Mar 2018 20:06

Fantatus System
Image

Download the system: 
FantatusSystem.pak
(7.35 KiB) Downloaded 92 times


User-eng-db file that features the object descriptions: 
user-eng-db - fantatus.cfg
(6.45 KiB) Downloaded 106 times

Remember, the User-eng-db.cfg file is created if you add a name to a random object in Space Engine.
 
User avatar
gixxer
Observer
Observer
Posts: 5
Joined: 16 Dec 2017
Location: Osnabrück, DE

Retro-Visor's Planetary Systems

19 Mar 2018 12:15

Amazing... Very nice systems you made. Love it!
"Only two things are infinite, the universe and human stupidity, and I'm not sure about the former." - Albert Einstein
System: Intel Core i7 7700k OC @4,8 GHz | Nvidia Geforce GTX 1080 Ti SLI | 32 GB RAM
 
User avatar
PlutonianEmpire
Pioneer
Pioneer
Posts: 409
Joined: 02 Nov 2016
Location: MinneSNOWta
Contact:

Retro-Visor's Planetary Systems

05 May 2018 22:09

One of my custom planets is causing a huge conflict with "tRetro-Visor-Systems-0980.pak", and causing SE to crash on start up, with the crash occurring at Initializing Planets - Planets Hierarchy. I've done whatever I can think of to fix my planet, but alas, no luck. SE.log is useless in this situation, it refuses to reveal what the conflict is *at all*.

Planet "Aurea Borealis (TPE)" {
 ParentBody "Sol"
 Class "Terra"
 Mass 0.908148
 Radius 6209.8526
 AlbedoBond 0.3783
 AlbedoGeom 0.462787
 Life {
 Class   "Organic"
 Type    "Multicellular"
 Biome   "Marine/Terrestrial"
 }
 Life {
 Class   "Exotic"
 Type    "Multicellular"
 Biome   "Marine/Terrestrial/Aerial"
 Panspermia true
 }
 RotationPeriod 25.161266
 RotationOffset 297.243736
 Obliquity 16.091567
 EqAscendNode 21.012
 Surface {
 SurfStyle       0.518289
 OceanStyle      0.956603
 Randomize      (-0.061, 0.987, -0.863)
 snowLevel       0.69
 icecapLatitude  0.625
 climatePole     1.0
 climateTropic   0.5875
 climateEquator  0.6125
 heightTempGrad  0.15
 mainFreq        1.375685
 venusMagn       0
 mareDensity     0
 terraceProb     0.258019
 erosion         0.114057
 montesMagn      0.2183044
 montesFreq      208.089
 montesSpiky     0.985254
 montesFraction  0.632679
 dunesMagn       0.0458766
 dunesFreq       44.6535
 hillsMagn       0.1317016
 hillsFreq       757.198
 hillsFraction   0.923004
 hills2Fraction  0.487663
 riversMagn      58.0862
 riversFreq      1.97318
 riversSin       5.29083
 riversOctaves   2
 canyonsMagn     0.0153224
 canyonsFreq     142.178
 canyonFraction  0.601026
 craterOctaves   0
 
 volcanoMagn     0
 volcanoFreq     1
 volcanoDensity  15
 volcanoOctaves  7.5
 volcanoActivity 0.85
 volcanoFlows    0.5
 volcanoRadius   1.275
 volcanoTemp     100000  // 4000000000000
 
 GlowMode        "Night"
 GlowColor      (1.0 0.9 0.4)
 GlowBright      2.42
 
 lavaCoverTidal  0
 lavaCoverSun    0
 lavaCoverYoung  0
 colorSea       (0.013671875, 0.2421875, 0.326171875, 1.00)
 colorShelf     (0.02734375, 0.484375, 0.65234375, 1.00)
 colorBeach     (0.83, 0.55, 0.26, 0.00)
 colorDesert    (0.72, 0.40, 0.14, 0.00)
 colorLowland   (0.83, 0.40, 0.22, 0.00)
 colorUpland    (0.72, 0.32, 0.18, 0.00)
 colorRock      (0.65, 0.50, 0.46, 0.00)
 colorSnow      (1.00, 1.00, 1.00, 1.00)
 colorLowPlants (0.100, 0.160, 0.070, 0.000)
 colorUpPlants  (0.090, 0.110, 0.040, 0.000)
 BumpHeight      19.830122
 BumpOffset      9.89367
 }
 Clouds {
 Height          2.545508
 BumpHeight      3.509497
 Velocity        56.32704512718
 mainFreq        1.106161
 Coverage        0.01276161
 stripeZones     2.720228
 stripeTwist     0.268497
 }
 Clouds {
 Height          3.4109102
 BumpHeight      7.9545496
 Velocity        40.2336129252
 }
 Clouds {
 Height          11.163647
 BumpHeight      1.545496
 Velocity        362.1024412475
 }
 Ocean {
 Height          9.89367
 }
 Atmosphere {
 Model "Earth"
 Greenhouse 79.978857
 Pressure 1.0
 Composition {
 N2  77.7729
 O2  20.8625
 Ar  0.9303
 H2O 0.4000
 CO2 0.0343
 }
 }
 Aurora {
 NorthLat    73.30878
 NorthLon    -122.6293
 NorthWidth  2585.213
 NorthBright 0.5
 SouthLat    -72.22795
 SouthLon    52.38643
 SouthWidth  2796.971
 SouthBright 0.5
 }
 NoRings true
 NoCometTail true
 Orbit {
 Period            1.88088989451605
 SemiMajorAxis     1.5237
 Eccentricity      0.02015
 Inclination       1.89109894
 AscendingNode     21.012
 ArgOfPericen      343.791
 MeanAnomaly       104.317862
 RefPlane       "Ecliptic"
 }
}

Moon "Boreal (TPE)" {
 ParentBody "Aurea Borealis (TPE)"
 Class "Selena"
 Mass 0.003359
 Radius 1151.270991
 AlbedoBond 0.18
 AlbedoGeom 0.216
 Color (1.00, 1.00, 0.90)
 NoClouds true
 NoOcean true
 NoAtmosphere true
 NoAurora true
 NoRings true
 NoCometTail true
 Orbit {
 Period            0.01607949275395551076148493856699 // 5.872909145131918 d
 SemiMajorAxis     8.9118423456332323318289048348066e-4  // 133319.2638920825 km
 Eccentricity      0.0599
 Inclination       2.5570
 AscendingNode     238.2859
 ArgOfPericen      201.7120
 MeanAnomaly       344.8566
 }
}

Moon "Aura (TPE)" {
 ParentBody "Aurea Borealis (TPE)"
 Class "Selena"
 Mass 0.009702
 Radius 1532.307496
 AlbedoBond 0.15
 AlbedoGeom 0.18
 Color (1.00, 0.95, 0.85)
 NoClouds true
 NoOcean true
 NoAtmosphere true
 NoAurora true
 NoRings true
 NoCometTail true
 Orbit {
 Period            0.09249048696667154756957495007747
 SemiMajorAxis     0.00287111131599220181948752830745
 Eccentricity      0.0431
 Inclination       1.1316
 AscendingNode     133.6103
 ArgOfPericen      79.1569
 MeanAnomaly       222.1710
 }
}


EDIT: This conflict occurs on 0.980. 0.980e loads fine.
Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )
 
User avatar
JackDole
World Builder
World Builder
Posts: 1044
Joined: 02 Nov 2016
Location: Terra

Retro-Visor's Planetary Systems

06 May 2018 04:54

PlutonianEmpire wrote:
Source of the post SE.log is useless in this situation, it refuses to reveal what the conflict is *at all*.


Your se.log may provide more information by setting 'CatalogLogLevel' to '4' in the main-user.cfg file. In the section 'Log'.
If it is not already on '4'.


I can also not retrace this bug. For me, 'tRetro-Visor-Systems-0980.pak' works perfectly together with your script in SE 0.980.
scr00000.png
 
User avatar
tomnts
Observer
Observer
Posts: 4
Joined: 22 Jul 2017
Location: France

Retro-Visor's Planetary Systems

06 May 2018 07:15

It does not work for me, the planets are lost to billions of kilometers.
 
User avatar
JackDole
World Builder
World Builder
Posts: 1044
Joined: 02 Nov 2016
Location: Terra

Retro-Visor's Planetary Systems

06 May 2018 07:58

tomnts wrote:
Source of the post It does not work for me, the planets are lost to billions of kilometers.

Post your se.log. It's in the 'system' folder of your SpaceEngine directory.
You can use Pastebin.com and post the link here.
 
User avatar
tomnts
Observer
Observer
Posts: 4
Joined: 22 Jul 2017
Location: France

Retro-Visor's Planetary Systems

06 May 2018 08:43

I think that's it

https://pastebin.com/4qHbNfe0

[sorry I had to edit this because it was killing my pc, content is at the link above]
 
User avatar
tomnts
Observer
Observer
Posts: 4
Joined: 22 Jul 2017
Location: France

Retro-Visor's Planetary Systems

06 May 2018 08:45

[quote="tomnts"]I think that's it

Thank you for your answer, I use pastebin.com but I do not think it has changed anything.[/quote]
 
User avatar
PlutonianEmpire
Pioneer
Pioneer
Posts: 409
Joined: 02 Nov 2016
Location: MinneSNOWta
Contact:

Retro-Visor's Planetary Systems

06 May 2018 21:33

JackDole wrote:
PlutonianEmpire wrote:
Source of the post SE.log is useless in this situation, it refuses to reveal what the conflict is *at all*.


Your se.log may provide more information by setting 'CatalogLogLevel' to '4' in the main-user.cfg file. In the section 'Log'.
If it is not already on '4'.


I can also not retrace this bug. For me, 'tRetro-Visor-Systems-0980.pak' works perfectly together with your script in SE 0.980.
scr00000.png

Here's the logs with the Retro Visor systems.
Attachments
Retro_Visor_Sys_Crash.7z
(398.52 KiB) Downloaded 20 times
Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )
 
User avatar
JackDole
World Builder
World Builder
Posts: 1044
Joined: 02 Nov 2016
Location: Terra

Retro-Visor's Planetary Systems

07 May 2018 01:52

PlutonianEmpire, you could try to remove the following addons:
CyphonSystem.pak
FantatusSystem.pak
JamesX1System.pak
TTA 17System.pak
Ventra-5System.pak

These packages are for SE 0.980_e and contain an error that could cause problems with SE 0.980. (Could, but not necessarily)
The TTA-17 system, CyphonSystem and JamesX1System are included in the 'tRetro-Visor-Systems-0980.pak'.

If that does not help, try using an empty addon folder with only those addons that you think are affected.
 
User avatar
PlutonianEmpire
Pioneer
Pioneer
Posts: 409
Joined: 02 Nov 2016
Location: MinneSNOWta
Contact:

Retro-Visor's Planetary Systems

07 May 2018 12:16

Ja works in 0.980_e now.

For 0.980 plain, Removing all listed systems except the 'tRetro-Visor-Systems-0980.pak' seems to have fixed it.

Thanks :)
Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )

Who is online

Users browsing this forum: No registered users and 1 guest