Page 42 of 73

Help with creating Mods and Addons

Posted: 04 Jun 2018 21:22
by kham132
Another problem I'm encountering. I gave my planet textures, but whenever I load the planet up it says this, "[00] ERROR: seTexture::CombineRGBandA(): RGB and Alpha textures must have 3 and 1 channel, equal bit depth and equaldimensions"
Any help? I've attached the maps and the script for the planet (find Aquaria 3) Thanks!

Help with creating Mods and Addons

Posted: 04 Jun 2018 22:47
by JackDole
kham132 wrote:
Source of the post Another problem I'm encountering.

If you want to comment out a block, it happens with:
/*
Surface
{
     ....
     ....
}
*/

(I suppose you want to comment out the first 'Surface' block in Planet 3.)

I do not know what you did wrong with the textures. I get something like this here, and no error messages.
scr00000_1.jpg

Maybe something is wrong with your 'Lights' texture.

Help with creating Mods and Addons

Posted: 05 Jun 2018 05:54
by Propulsion Disk
End of page 41, I got totally looked over.

Help with creating Mods and Addons

Posted: 05 Jun 2018 09:16
by Mosfet
Propulsion Disk, I'm afraid "did everything it said but it still doesn't work" doesn't help anybody to help you. If you followed the manual, then the issue could be some error in the obj file, or wrong normals, or something else entirely, like the folder named /spacecrafts which must be  /spacecraft instead. It's not that simple, even experienced modders have issues like yours. Check your se.log file, it's in your SpaceEngine/system/folder. It should have some clues regarding your problem. You can use https://pastebin.com/ to post your se.log file, and give us here the address.

Propulsion Disk wrote:
Source of the post End of page 41, I got totally looked over.

You don't have much experience with forums, do you ;)

Help with creating Mods and Addons

Posted: 05 Jun 2018 09:33
by Propulsion Disk
Hello Mosfet, and yes, this is my first forum EVER! Anyway, I did all the stuff that the manual said like make the faces triangles, create mat library, save vertices and stuff like that, and my files are addons/Auriga/models/spacecraft/ErichthoniusAuriga/Charioteer and addons/Auriga/textures/spacecraft/ErichthoniusAuriga/Charioteer so I got that right. I copied and pasted the .sss file that was in the manual, (but I did open it in document though.) I exported all my models to .obj and .stl and put them into the "Charioteer" folder at the end of those other folders. And after all that, I STILL CAN'T GET TO WORK! It won't even show up in the ship builder at all! And I wait for it to show up but it never does, even after a half hour. (FYI) I use blender to edit the models so that might do something, maybe, and when I open my .obj it brings me to Microsoft 3d print, and when I open my .stl it brings me to notepad. So yeah that could be it, because that is kinda weird. But I hope you can maybe help me now so yeah.

Help with creating Mods and Addons

Posted: 05 Jun 2018 18:20
by Propulsion Disk
Mosfet wrote:
Source of the post Check your se.log file, it's in your SpaceEngine/system/folder.

it said that it was checked through as a data directory like this.
SpaceEngine Version 0.9.8.0 beta
STARTING
[MT] Scanning data directories
[MT] Data directory "data"
[MT] Data directory "addons"
[MT] Data directory "addons Auriga.pak" (<- THAT)
[MT] Loading script "config/main-def.cfg"
[MT] Loading script "config/main-user.cfg"
[MT] Loading  image "data/textures/common/splash09.jpg"
[MT] 20 localizations found
DONE
So yeah, it was that except without the "(<- THAT)" in it.

Help with creating Mods and Addons

Posted: 06 Jun 2018 02:37
by Mosfet
Propulsion Disk wrote:
Source of the post  I copied and pasted the .sss file that was in the manual,

Propulsion Disk wrote:
Source of the post It won't even show up in the ship builder at all!

If it doesn't show the name you wrote of your ship into the .sss file, the .sss file is wrong, then. Or its contents.

Propulsion Disk wrote:
SpaceEngine Version 0.9.8.0 beta
STARTING

That's only few lines of your se.log, probably there are clues elsewhere.
I see you have more than 10 posts now, it means you can upload your se.log file directly as an attachment in a post by clicking the "Add files" button.

Making a .pak is not a mandatory passage for a working mod, only good for distributing a finished product. It's the last step to do when all the things are working as you intended.

.obj files are opened by windows 10 3d builder by default if you double-click on them, that's not an issue.
.mtl and .sml files are indeed text files, so they can be opened by a text editor.

Since you could also have a .sss file that is wrongly saved as .sss.txt or something similar, make sure you can see and modify file extensions as explained here: https://www.online-tech-tips.com/windows-10/show-file-extensions-and-hidden-files-in-windows-10/

Check also if your importing process is correct by following this ettore_bilbo's guide in powerpoint: http://forum.spaceengine.org/viewtopic.php?f=3&t=388

Help with creating Mods and Addons

Posted: 06 Jun 2018 05:47
by Propulsion Disk
Mosfet wrote:
Source of the post That's only few lines of your se.log, probably there are clues elsewhere.

I can't show you that right now because I deleted my obj and stl files, but I still have the models!
But here it is anyway.

Help with creating Mods and Addons

Posted: 06 Jun 2018 06:02
by Propulsion Disk
Mosfet wrote:
Source of the post Since you could also have a .sss file that is wrongly saved as .sss.txt or something similar, make sure you can see and modify file extensions as explained here: https://www.online-tech-tips.com/window ... indows-10/

The manual said to open it in notepad, as a folder, which I can't do because folders do not have "open with" options. I went to the site you gave me and did what it said, but that didn't change anything.

Help with creating Mods and Addons

Posted: 06 Jun 2018 06:34
by Propulsion Disk
I'll get to making new .obj and .stl files of a different ship now so you can see the problems in se.log (PS) the reason I'm not doing the charioteer is because there are NINE of BOTH .obj AND .stl so it would take forever. But I'll make this spacecraft the same exact way that I would make the charioteer!

Help with creating Mods and Addons

Posted: 06 Jun 2018 07:02
by Propulsion Disk
It's done now! it's called Pocket (don't ask me why,) and it was made the exactly same way the charioteer was made with of coarse a different shape. So here it is! the new se.log file!
se.log

Help with creating Mods and Addons

Posted: 06 Jun 2018 15:48
by Mosfet
Propulsion Disk, SpaceEngine doesn't start to convert the obj mesh file until you don't build the new ship from the ship list.
But you need a correct .sss file for that ship, which it appears to be your first obstacle.

Propulsion Disk wrote:
Source of the post The manual said to open it in notepad, as a folder, which I can't do because folders do not have "open with" options.

I think there's a misunderstanding. Manual says
To add the Discovery ship, create an empty file with name DiscoveryShip.sss in the
models folder addons/2001/models/spacecraft/Odyssey2001/Discovery/. Open it in
Notepad and type the code shown below

"open it in notepad" refers to an empty text file, with extension .sss, placed in your case inside the addons/models/spacecraft/ErichthoniusAuriga/Charioteer folder of your mod.

Help with creating Mods and Addons

Posted: 06 Jun 2018 16:15
by Propulsion Disk
 
Mosfet wrote:
Source of the post I think there's a misunderstanding. Manual says To add the Discovery ship, create an empty file with name DiscoveryShip.sss in themodels folder addons/2001/models/spacecraft/Odyssey2001/Discovery/. Open it inNotepad and type the code shown below"open it in notepad" refers to an empty text file, with extension .sss, placed in your case inside the addons/models/spacecraft/ErichthoniusAuriga/Charioteer folder of your mod.

I tried to just do a text file a few times but it didn't work.
Mosfet wrote:
Source of the post Propulsion Disk, SpaceEngine doesn't start to convert the obj mesh file until you don't build the new ship from the ship list.

What's the ship list? Is it the ship builder? Because if it is.
Propulsion Disk wrote:
Source of the post It won't even show up in the ship builder at all! And I wait for it to show up but it never does, even after a half hour.

 So yeah, but when I sent you the "Pocket" se.log file the .sss file was a compressed folder (Whoops) so I'll send you the se.log file with the right .sss file.
se.log

Help with creating Mods and Addons

Posted: 06 Jun 2018 17:57
by Mosfet
Propulsion Disk wrote:
Source of the post so I'll send you the se.log file with the right .sss file.

If you don't see the name of your ship in the ship builder, then your .sss file contains some wrong syntax.
If you can't create a text file in your mod folder and rename its extension to .sss, then I'm afraid you have windows issues unrelated to SpaceEngine.
Let's see the .sss file, could you attach it here?

Help with creating Mods and Addons

Posted: 06 Jun 2018 18:04
by Propulsion Disk
Mosfet wrote:
Source of the post Let's see the .sss file, could you attach it here?

YOS! "E.G.G.M.A.N."
Tester.sss.txt