Free planetarium

 
User avatar
Olegson
Observer
Observer
Posts: 15
Joined: 07 Jul 2017
Location: Germany

Help with creating Mods and Addons

26 Jul 2017 07:25

Mr. Abner wrote:
Olegson wrote:
Mr. Abner wrote:
This thing still rattles around my brain... do you mind if I ask why it is not possible at this time? If the ship is already in Space Engine, then the textures are readily available for editing. What am I missing?
-Alex

It would only work with pure black textures (correct me if I'm wrong) and it's not the result I would like to achieve.

You will in effect transfer the texture to the emission map. This will have the effect of making the object permanently "lit" yet unaffected by external lighting such as stars or planetshine. I believe this is exactly the effect you are looking for.

Okay, a few days back I tried the method you are suggesting to me... it seemed that I messed things up in a hurry and I was convinced that it didn't work (even if it seems logical). I tried it again now after solving other problems and it seems to work! Thanks for convincing me to try it again...and sorry for my impatience :)
 
alfa015
Observer
Observer
Posts: 16
Joined: 26 Jul 2017

Help with creating Mods and Addons

26 Jul 2017 15:37

skywalker66 wrote:
I have noticed that a giant daytime cyclone for a new exoplanet HD 10180 b I had made for HIP 7599 (or HD 10180) was somewhat off the center of planet's dayside by more than 120 degrees into the nightside. How do I make the cyclone to center on the daytime, if anyone know of right method to do it? Thanks in advantage

scr00018.jpg

how is it possible to remove cyclones while editing a planet? I set the values to 0 but still the eye remains
 
Mr. Abner
Space Pilot
Space Pilot
Posts: 84
Joined: 08 Jun 2017
Location: Mississauga

Help with creating Mods and Addons

26 Jul 2017 17:20

Olegson wrote:
Mr. Abner wrote:
Olegson wrote:
It would only work with pure black textures (correct me if I'm wrong) and it's not the result I would like to achieve.

You will in effect transfer the texture to the emission map. This will have the effect of making the object permanently "lit" yet unaffected by external lighting such as stars or planetshine. I believe this is exactly the effect you are looking for.

Okay, a few days back I tried the method you are suggesting to me... it seemed that I messed things up in a hurry and I was convinced that it didn't work (even if it seems logical). I tried it again now after solving other problems and it seems to work! Thanks for convincing me to try it again...and sorry for my impatience :)

Excellent! Looking forward to seeing the results in the image dump thread. :)
 
User avatar
XBrain130
Explorer
Explorer
Posts: 218
Joined: 26 Nov 2016
Location: Italy
Contact:

Help with creating Mods and Addons

27 Jul 2017 04:23

Does someone know what is the problem when a ship seems to have fully functional textures despite being rendered as fully dark unless the ambient lighting is raised?

scr00028.png
scr00029.png


I tried to edit Specular Color, Albedo, and Exposure ofthe model, but nothing changed. And SE.log reports no errors loading the model or the texture.
SpaceEngine's Italian Discord server: https://discord.gg/NhQbEbC
 
User avatar
PlutonianEmpire
Explorer
Explorer
Posts: 236
Joined: 02 Nov 2016
Location: MinneSNOWta
Contact:

Help with creating Mods and Addons

28 Jul 2017 01:21

Other than trial and error (which would require countless reboots of SpaceEngine), how do I find out which comets in Sol do not have Periods specified in their Orbit tag? In my Spitfire mod, I split Sol into a circumbinary. However, due to the bug that incorrectly calculates circumbinary orbital periods for bodies with no Periods specified, several comets wound up hovering at the barycenter for eternity, requiring me to start adding "Remove" tags for each these wayward comets.
Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )
 
User avatar
JCandeias
Astronaut
Astronaut
Posts: 64
Joined: 14 Nov 2016
Location: Portugal

Help with creating Mods and Addons

28 Jul 2017 06:49

XBrain130 wrote:
Source of the post Does someone know what is the problem when a ship seems to have fully functional textures despite being rendered as fully dark unless the ambient lighting is raised?

Probably because you've created it in interstellar space. Out there they don't have a light source to illuminate them, and therefore they appear black.
My addons are to be found at JCandeias' Ships

Current count: 2
 
User avatar
XBrain130
Explorer
Explorer
Posts: 218
Joined: 26 Nov 2016
Location: Italy
Contact:

Help with creating Mods and Addons

28 Jul 2017 06:56

JCandeias wrote:
Source of the post Probably because you've created it in interstellar space. Out there they don't have a light source to illuminate them, and therefore they appear black.

If you read the infodump on the top-left, you'll see I'm only 4 AU from the Sun.
SpaceEngine's Italian Discord server: https://discord.gg/NhQbEbC
 
User avatar
JackDole
Pioneer
Pioneer
Posts: 575
Joined: 02 Nov 2016
Location: Terra

Help with creating Mods and Addons

28 Jul 2017 07:00

PlutonianEmpire wrote:
Source of the post Other than trial and error (which would require countless reboots of SpaceEngine), how do I find out which comets in Sol do not have Periods specified in their Orbit tag?

You could extract the 'Comets.sc' file from the 'Catalogs0980.pak' archive and look there.
 
User avatar
PlutonianEmpire
Explorer
Explorer
Posts: 236
Joined: 02 Nov 2016
Location: MinneSNOWta
Contact:

Help with creating Mods and Addons

28 Jul 2017 08:05

Yes, but that still requires manual looking. Is there a way to automatically and instantly know which comets are the culprits?
Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )
 
User avatar
JackDole
Pioneer
Pioneer
Posts: 575
Joined: 02 Nov 2016
Location: Terra

Help with creating Mods and Addons

28 Jul 2017 10:46

PlutonianEmpire,
in fact, are all comets in the 'Comets.sc' file without 'Period', except the first six.
 
User avatar
PlutonianEmpire
Explorer
Explorer
Posts: 236
Joined: 02 Nov 2016
Location: MinneSNOWta
Contact:

Help with creating Mods and Addons

28 Jul 2017 14:24

Just checked, you're right. 6 comets out of... 235 comets. :O
Specs: Dell Inspiron 5547 (Laptop); 8 gigabytes of RAM; Processor: Intel® Core™ i5-4210U CPU @ 1.70GHz (4 CPUs), ~2.4GHz; Operating System: Windows 7 Home Premium 64-bit; Graphics: Intel® HD Graphics 4400 (That's all there is :( )
 
User avatar
Betelgeuze
Space Pilot
Space Pilot
Posts: 83
Joined: 24 Apr 2017
Location: Belgium

Help with creating Mods and Addons

30 Jul 2017 00:30

I need help for my custom system. Elliella (the gas giant) is on second cell and weird barycenter with -999999999999696 in solar system browser

The custom system is from SE 0.9.7.3. I'm using 0.9.7.3  because 0.9.8.0 is not working on my computer due to lack of RAM and too old

Image

Here is two sc files of my custom system
Attachments
EllaStar.sc
(150 Bytes) Downloaded 14 times
EllaSystem.sc
(103.24 KiB) Downloaded 12 times
 
User avatar
JackDole
Pioneer
Pioneer
Posts: 575
Joined: 02 Nov 2016
Location: Terra

Help with creating Mods and Addons

30 Jul 2017 01:22

Betelgeuze wrote:
Source of the post I need help for my custom system. Eliella (the gas giant) is on second cell and weird barycenter with -999999999999696 in solar system browser

Try using 'MassSol' as a parameter for the stars, not 'Mass'.
scr00036.jpg
 
User avatar
Betelgeuze
Space Pilot
Space Pilot
Posts: 83
Joined: 24 Apr 2017
Location: Belgium

Help with creating Mods and Addons

30 Jul 2017 01:29

JackDole wrote:
Try using 'MassSol' as a parameter for the stars, not 'Mass'.
scr00036.jpg

thank you so much It's much better!
Image
 
User avatar
ettore_bilbo
Astronaut
Astronaut
Posts: 67
Joined: 11 Nov 2016

Help with creating Mods and Addons

31 Jul 2017 12:55

XBrain130 wrote:
Source of the post Does someone know what is the problem when a ship seems to have fully functional textures despite being rendered as fully dark unless the ambient lighting is raised?

in my previous experiences this happens when there aren't information about normals in the obj. open obj with blender and re-export with those option flagged
Attachments
Immagine.jpg
Immagine.jpg (17.4 KiB) Viewed 380 times

Who is online

Users browsing this forum: Bing [Bot] and 1 guest