симулятор вселенной

  • 1
  • 22
  • 23
  • 24
  • 25
  • 26
 
Cromartie
Наблюдатель
Сообщения: 1
Зарегистрирован: 15 апр 2020

Баги и их устранение в SpaceEngine 0.9.8.0

15 апр 2020 01:09

Ошибка загрузки шейдеров генератора текстур, как это исправить? Заранее спасибо)
 
Аватара пользователя
Алексей63
Космонавт
Сообщения: 68
Зарегистрирован: 22 ноя 2017

Баги и их устранение в SpaceEngine 0.9.8.0

11 июн 2020 15:51

Спасибо, что чуть подправили, хоть и все равно далековато от реальности, режим авто. но и в том, и в другом режиме меняется цвет звезд при изменении расстояния до звезды. особенно это заметно на красных карликах, которые становятся белыми, чуть подальше - снова красными. подобная ошибка была и в одной из предыдущих версий, но не в том фоторежиме, которым я пользовался, поэтому не мешала. здесь она и в авто, и в HDR. Хотелось бы ликвидировать ее, как и просвет центральной звезды сквозь горы и тучи (на большинстве планет, особенно в авто. Напрягает также блик на грунте от светила за горизонтом или за тучами
 
Аватара пользователя
dimacujo
Наблюдатель
Сообщения: 5
Зарегистрирован: 09 мар 2019

Баги и их устранение в SpaceEngine 0.9.8.0

12 авг 2020 16:45

 Ребят, привет.
С чем может быть связано, может есть более точное дополнение?
Я пролетаю с многими астеройдами  такими как Апофис, Дуэнде во времени их максимального сближения с Землей. Но расстояния с Википедией и расчетами НАСА отличаются. Да они приближаются в нужный отрезок времени, но разница в км огромна. Может есть мод более точной физики астрономических тел? 
 
maximtamtura111
Наблюдатель
Сообщения: 1
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

21 сен 2020 11:50

У меня Space Engine не запускается на Windows 10 вот мо se.log
Вложения
se.log
(10.78 КБ) 49 скачиваний
 
Павел
Наблюдатель
Сообщения: 6
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

21 сен 2020 18:19

Выходит напрасно я купил GeForce RTX 2080 Super 8Гб. Space Engine на ней не запускается. И в 7-ке и в десятке пишет ошибка ядра ntdll.dll. Причём в любой версии Space Engine. Ставлю назад GeForce GTX 1060 6Гб и все работает. Видать движок такой. Как старый дед инвалид новое железо не переваривает.
 
Аватара пользователя
Доминго Казанова
Исследователь
Сообщения: 213
Зарегистрирован: 25 ноя 2016

Баги и их устранение в SpaceEngine 0.9.8.0

22 сен 2020 01:24

Павел, на 2080 все прекрасно запускается. для начала надо снести драйверы грамотно, а потом накатить по новой.
 
Аватара пользователя
SpaceEngineer
Автор SpaceEngine
Автор темы
Сообщения: 1020
Зарегистрирован: 22 авг 2016
Откуда: Санкт-Петербург
Контактная информация:

Баги и их устранение в SpaceEngine 0.9.8.0

22 сен 2020 13:29

А 0.990 не пробовали? Старые версии я больше не поддерживаю.
 
Павел
Наблюдатель
Сообщения: 6
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

01 окт 2020 21:18

Сильно сомневаюсь я что версия 0.9.9.0 поможет. Дело  не в драйвере видеокарты и не в операционной системе. И даже не в 11 евро. А думаю что Вы и сами не знаете в чём. 
 
Аватара пользователя
SpaceEngineer
Автор SpaceEngine
Автор темы
Сообщения: 1020
Зарегистрирован: 22 авг 2016
Откуда: Санкт-Петербург
Контактная информация:

Баги и их устранение в SpaceEngine 0.9.8.0

12 окт 2020 01:07

У меня самого RTX 2080 8 Гб, на ней и веду разработку. Так что чините вашу систему.
 
Павел
Наблюдатель
Сообщения: 6
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

16 окт 2020 19:02

 Система у меня не одна. И на всех одно и тоже. В системном блоке установлены:
Четыре винчестера Seagate по 2Тб, и М2 NVME накопитель от ADATA также на 2Тб. Процессор <XEON E5 1650 v2> установлен на плату <Jingsha X79 P3>  китайского производства. Использую 8*4=32Гб DDR3 ECC REG серверной памяти. На каждом диске установлены по две операционных системы. Десятка LTSC и семерка SP1 от OVGorsky . Все 64-х разрядные. Ну и видеокарты упомянутые выше, которые переставляю, когда хочу полетать над другими планетами. Драйвер на них один и тот же ставлю 452.06
Во всех системах установлены CAM и CAD  системы, такие как SprutCAM , FeatureCAM, KOMPAS-3D и еще несколько. (то что касается работы). А кроме того установлены следующие игры:
 Horizon Zero Dawn Complete Edition; No Man's Sky; The Witcher 3 Wild Hunt; Watch Dogs 2; Assassin's Creed Origins; Just Cause 3; Far Cry 5; Shadow of the Tomb Raider; Detroit Become Human; Metro Exodus; Assassins Creed Odyssey; The Elder Scrolls 5 Skyrim; Subnautica; Battlefield 5; Rise of the Tomb Raider; GTA 5; Star Wars Jedi: Fallen Order;
Final Fantasy 15 Windows Edition; Mass Effect Andromeda; X4 Foundations.
И все это на всех системах и накопителях запускается и прекрасно работает. Кроме Вашего SpaceEngine любой версии запущенного из любой системы и любого накопителя. Имеет только значение – какая видеокарта вставлена в PCI-E сокет.
Если ASUS GeForce GTX 1060 6Гб, то  SpaceEngine любой версии запускается и прекрасно работает на любом диске и Виндовсе.  Если же Вставляю в сокет - GIGABYTE GeForce RTX 2080 Super  8Гб - то лишь кратковременно появляется окно заставки и тут же пропадает с появлением окна ошибки. В чём дело – даже не догадываюсь.  Ставил разные драйвера из последних, новее чем 452.06.  Толку ноль.  Остаётся другую мат.плату и процессор по-пробовать, но с этим пока проблемы. В любом случае, когда по-пробую, отпишусь.
 
Аватара пользователя
SpaceEngineer
Автор SpaceEngine
Автор темы
Сообщения: 1020
Зарегистрирован: 22 авг 2016
Откуда: Санкт-Петербург
Контактная информация:

Баги и их устранение в SpaceEngine 0.9.8.0

17 окт 2020 09:31

Возможно, SE не чистит папку кэша, но это маловероятно.
 
Аватара пользователя
Yasconum
Наблюдатель
Сообщения: 2
Зарегистрирован: 17 окт 2020

Баги и их устранение в SpaceEngine 0.9.8.0

17 окт 2020 16:00

Вставлю свои 5 копеек в обсуждение, может пригодится кому-нибудь.
Прикупил на днях Nvidia GeForce GT 730 специально для «Space Engine» вместо Nvidia GeForce GT 520. Поставил, всё работало нормально, только перестали отображаться крупным планом планеты, спутники, астероиды и т.д. В программировании и тонкостях железа я глубоко не разбираюсь, но рассуждая логически пришел к выводу, что во время установки на ПК, «SE» (ver. 0.9.8.0) запоминает "внутри себя" параметры видеокарты и формирует под это дело файл(патч). Когда меняем вид.карту, у которой характеристики отличаются от 1-ой карты, то «SE» не "подстраивается" под новые параметры и не меняет их, а продолжает использовать старые. В итоге имеем вышеописанные глюки. Так мне процесс представляется ... Самым простым (для меня) решением проблемы, стала переустановка «SE» с новой картой. Продвинутые в плане программирования пользователи, наверное, могут подправить файл или патч от 1-ой вид.карты до нужной кондиции, я не из их числа. Отсутствие крупного плана объектов, для меня стало самым "трагичным" глюком в «SE»! Переустановка с зачисткой реестра и удалением оставшихся файлов, решила все проблемы. Сейчас всё Ок!
PS. С дровами нормально получилось, к 730-ой все подошло, обновлять ничего не пришлось. GeForce GT 520 в основном работала нормально, хотя, время от времени вылезали всякие бяки. А поскольку карта не вписывалась в минимальные тех.требования, то я, собственно, особо не переживая, списывал все глюки-бяки на этот счет.
Вложения
NVID-SYS.png
Все, что ни делается, - все к лучшему?
 
Павел
Наблюдатель
Сообщения: 6
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

18 окт 2020 22:46

Спасибо что подсказали, Владимир. Удалил содержимое папки кеша и процесс кеширования пошёл. Вот только последующий процесс запуска симулятора крашится на новых драйверах. Пришлось в десятке откатить видеодрайвер до версии 431.68 . Только на этой версии SE любой версии компилирует шейдеры, запускается, и прекрасно работает. А для семерки пришлось откатить до версии 431.60 . Загуглил ситуацию с драйверами. NVIDIA оказывается сменила парадигму ))). Это не лучше чем у меня на заводе. Раз в квартал меняется ген.директор а вместе с ним и парадигма.  Теперь во всех играх как и в Detroit Become Human и в  Horizon Zero Dawn перед первым запуском или при смене видеокарты ресурсы игры будут подстраиваться под оборудование. Еще раз, СПАСИБО Вам уважаемый  SpaceEngineer. Успехов Вам в ваших разработках. Прекрасную вещь Вы создали!  
 
Аватара пользователя
SpaceEngineer
Автор SpaceEngine
Автор темы
Сообщения: 1020
Зарегистрирован: 22 авг 2016
Откуда: Санкт-Петербург
Контактная информация:

Баги и их устранение в SpaceEngine 0.9.8.0

19 окт 2020 00:29

Yasconum писал(а):
Прикупил на днях Nvidia GeForce GT 730 специально для «Space Engine» вместо Nvidia GeForce GT 520.

Ой, это же совсем слабое железо...

Yasconum писал(а):
В программировании и тонкостях железа я глубоко не разбираюсь, но рассуждая логически пришел к выводу, что во время установки на ПК, «SE» (ver. 0.9.8.0) запоминает "внутри себя" параметры видеокарты и формирует под это дело файл(патч).

Интуиция вас не подвела, SE формирует не файл, а целую папку с железо-зависимыми данными - SpaceEngine\cache. Вот её-то и нужно удалить при смене железа или обновлении драйверов. Править ничего не нужно, просто удалить, SE сформирует новую сам.
Но это касается старых версий. Современная стимовская сама детектит смену железа/драйвера и чистит кэш.
 
Аватара пользователя
SpaceEngineer
Автор SpaceEngine
Автор темы
Сообщения: 1020
Зарегистрирован: 22 авг 2016
Откуда: Санкт-Петербург
Контактная информация:

Баги и их устранение в SpaceEngine 0.9.8.0

19 окт 2020 00:30

Павел писал(а):
Спасибо что подсказали, Владимир. Удалил содержимое папки кеша и процесс кеширования пошёл. Вот только последующий процесс запуска симулятора крашится на новых драйверах. Пришлось в десятке откатить видеодрайвер до версии 431.68 . Только на этой версии SE любой версии компилирует шейдеры, запускается, и прекрасно работает. А для семерки пришлось откатить до версии 431.60 .

Если это касается 0.980, то да, нужно откатывать драйвера. В новых что-то сделали, из-за чего старая версия перестала запускаться. Но т.к. я старую версию больше не поддерживаю, то увы.
 
Аватара пользователя
Yasconum
Наблюдатель
Сообщения: 2
Зарегистрирован: 17 окт 2020

Баги и их устранение в SpaceEngine 0.9.8.0

19 окт 2020 01:34

SpaceEngineer писал(а):
Источник цитаты Ой, это же совсем слабое железо...

Железо буду обновлять, но постепенно, не в один раз и не только видеокарту.
Все, что ни делается, - все к лучшему?
 
Павел
Наблюдатель
Сообщения: 6
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

20 окт 2020 17:12

Где-то на просторах Тырнета скачал версию которая на установочной  картинке сообщает что она версия 0.990.33.1625.вета. Так вот на ней и пришлось откатывать драйвер. А полноценную версию как купить?
 
Павел
Наблюдатель
Сообщения: 6
Зарегистрирован: 21 сен 2020

Баги и их устранение в SpaceEngine 0.9.8.0

20 окт 2020 17:14

И будет ли она работать без отката драйвера ?
 
Аватара пользователя
SpaceEngineer
Автор SpaceEngine
Автор темы
Сообщения: 1020
Зарегистрирован: 22 авг 2016
Откуда: Санкт-Петербург
Контактная информация:

Баги и их устранение в SpaceEngine 0.9.8.0

20 окт 2020 19:20

Здесь можно купить. Работает, конечно же, на свежих дровах.
https://store.steampowered.com/app/314650/SpaceEngine/
 
introsauron
Наблюдатель
Сообщения: 1
Зарегистрирован: 23 окт 2020

Баги и их устранение в SpaceEngine 0.9.8.0

24 окт 2020 07:46

Вылетает при запуске. Виден курсор мыши и далее без ошибок на рабочий стол.

Компьютер соответствует требованиям.
Помогите пожалуйста, я лютый фанат космоса)

Вот лог
Вложения
se.log
(127.67 КБ) 11 скачиваний
  • 1
  • 22
  • 23
  • 24
  • 25
  • 26

Сейчас на сайте

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость